JPIV Throwing Exceptions

If you are trying to do some particle image velocimetry, and JPIV starts, but throws exceptions, you probably need to install the Java Advanced Imaging Library (agh!). This is because Java Webstart, despite it’s best efforts, cannot install the JAI(L) automatically.

I installed all three installers from this page, which is a pain to find. After that, the errors stopped, and the velocimetry began.

Much of my career has revolved around Java/Android/Webstart projects. Why is Java still such a horrendously high-friction thing? It’s sad.

This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *